Re: [GIT PULL] x86/cache updates for 4.21
From: Linus Torvalds
Date: Wed Dec 26 2018 - 15:27:15 EST
On Sun, Dec 23, 2018 at 4:49 AM Borislav Petkov <bp@xxxxxxx> wrote:
> - The generalization of the RDT code to accommodate the addition of AMD's
> very similar implementation of the cache monitoring feature.
I've pulled this, but I think the new config option name is bad.
I think it should probably have been called "X86_RESCTRL" instead of
just "RESCTRL". That's way too generic a name for something that is
(at least currently) very much an x86 feature.
It not only is x86-specific right now, it's specific to very few
resources. It's not like this is some generic resource control, it's
very much about low-level CPU resources. That should show in the name.
I've left it alone, and maybe it might even be cross-architecture some
day (there's already a hack in the scheduler), but I think it's a bit
misleading to have so a common name for such a specialized thing.
Even if it some day gets to be cross-architecture and isn't limited to
x86, at that point it _still_ wouldn't be "RESCTRL", it would be
"CPU_RESCTRL" or something.