Re: [GIT PULL] x86/cache updates for 4.21
From: Borislav Petkov
Date: Wed Dec 26 2018 - 15:57:16 EST
On Wed, Dec 26, 2018 at 12:26:12PM -0800, Linus Torvalds wrote:
> I've pulled this, but I think the new config option name is bad.
> I think it should probably have been called "X86_RESCTRL" instead of
> just "RESCTRL". That's way too generic a name for something that is
> (at least currently) very much an x86 feature.
Right you are...
> It not only is x86-specific right now, it's specific to very few
> resources. It's not like this is some generic resource control, it's
> very much about low-level CPU resources. That should show in the name.
> I've left it alone, and maybe it might even be cross-architecture some
> day (there's already a hack in the scheduler),
> but I think it's a bit misleading to have so a common name for such a
> specialized thing.
> Even if it some day gets to be cross-architecture and isn't limited to
> x86, at that point it _still_ wouldn't be "RESCTRL", it would be
> "CPU_RESCTRL" or something.
... and yap, that is already going in the cross-arch direction as
apparently there's work to have a similar thing on the ARM64 side:
The intent is, AFAIU, to keep at least the user interface in the resctrl
fs the same as on x86 so that there's no unnecessary user confusion. And
from peeking at that patchset a bit, it looks like we'll need a generic
which should enable the arch-agnostic piece in fs/ and then
the arch-specific counterpart which we'll probably put behind
CONFIG_X86_RESCTRL and CONFIG_ARM64_RESCTRL, respectively.
I guess I can send you a patch renaming the x86 config option to
X86_RESCTRL and the ARM64 side will fall into place when ready. And
it'll extract the generic bits into that separate generic config option.
SUSE Linux GmbH, GF: Felix ImendÃrffer, Jane Smithard, Graham Norton, HRB 21284 (AG NÃrnberg)