Re: [GIT PULL] x86/cache updates for 4.21

From: Linus Torvalds
Date: Wed Dec 26 2018 - 16:02:49 EST

On Wed, Dec 26, 2018 at 12:56 PM Borislav Petkov <bp@xxxxxxx> wrote:
> The intent is, AFAIU, to keep at least the user interface in the resctrl
> fs the same as on x86 so that there's no unnecessary user confusion. And
> from peeking at that patchset a bit, it looks like we'll need a generic
> which should enable the arch-agnostic piece in fs/ and then
> the arch-specific counterpart which we'll probably put behind
> CONFIG_X86_RESCTRL and CONFIG_ARM64_RESCTRL, respectively.
> I guess I can send you a patch renaming the x86 config option to
> X86_RESCTRL and the ARM64 side will fall into place when ready. And
> it'll extract the generic bits into that separate generic config option.
> Thoughts?

That sounds mostly good to me. Except I still think that
"CONFIG_RESCTRL" is too generic, because it's really not about
resources in general, it's literally about specific CPU resources.

So I'd prefer to call the option for the generic code
"CONFIG_CPU_RESCTRL", which is then selected by the arch option (ie

Anyway, this is mostly bikeshedding, but naming is fairly important.
But not time-critical at this point,