RE: [PATCH V15 4/6] i2c: tegra: Add DMA support
From: Sowjanya Komatineni
Date: Fri Feb 08 2019 - 10:58:23 EST
> > Please use "release_dma:" variant that I suggested in the comment to v14 because:
> > >
> > 1) It's just a good (and common-style in kernel) tone to unwind errors handling in the opposite order, it makes code more straight forward and helps to avoid silly mistakes.
> > 2) It keeps the current code consistent in regards to probe error-handling.
> Can move tegra_i2c_release_dma under the same disable_div_clk label before clk_disable
> Order in probe is
clk_enable in case of multimaster mode
> unwinding should be order is
> Probe failure from tegra_i2c_init_dma, tegra_i2c_init, devm_request_irq, i2c_add_numbered_adapter all of them perform goto disable_div_clk
> I can add tegra_i2c_release_dma before performing clock disable under same disable_div_clk so all existing disable_div_clk labels remain same.
> Otherwise adding new label release_dma causes all goto disable_div_clk statement also to be changed but its same as adding release_dma under disable_div_clk above the clk_disable.
OK, please ignore above. will add release_dma to show explicitly for readability.
With release_dma all error handlers performing disable_clk_div need to go thru release dma and disable_clk_div label is not needed.
So having release dma under disable_clk before clk_disable function is also same.
Please confirm if this is ok to use same disable_div_clk or do you prefer release_dma label removing disable_div_clk
> > >
> > > disable_rpm:
> > > pm_runtime_disable(&pdev->dev);
> > [snip]
> > Please also address my comment to the "fix maximum transfer size" patch. And please add Wolfram Sang to the CC list.
> > Looks like v16 should be the final, so with everything being addressed:
> > Reviewed-by: Dmitry Osipenko <digetx@xxxxxxxxx>
> > Tested-by: Dmitry Osipenko <digetx@xxxxxxxxx>