[RESEND][PATCH v3 00/26] drm: Kirin driver cleanups to prep for Kirin960 support

From: John Stultz
Date: Wed Aug 14 2019 - 14:47:11 EST


Just wanted to resend this patch set so I didn't have to
continue carrying it forever to keep the HiKey960 board running.

This patchset contains one fix (in the front, so its easier to
eventually backport), and a series of changes from YiPing to
refactor the kirin drm driver so that it can be used on both
kirin620 based devices (like the original HiKey board) as well
as kirin960 based devices (like the HiKey960 board).

The full kirin960 drm support is still being refactored, but as
this base kirin rework was getting to be substantial, I wanted
to send out the first chunk, so that the review burden wasn't
overwhelming.

The full HiKey960 patch stack can be found here:
https://git.linaro.org/people/john.stultz/android-dev.git/log/?h=dev/hikey960-mainline-WIP

thanks
-john

Cc: Rongrong Zou <zourongrong@xxxxxxxxx>
Cc: Xinliang Liu <z.liuxinliang@xxxxxxxxxxxxx>
Cc: David Airlie <airlied@xxxxxxxx>
Cc: Daniel Vetter <daniel@xxxxxxxx>
Cc: dri-devel <dri-devel@xxxxxxxxxxxxxxxxxxxxx>
Cc: Sam Ravnborg <sam@xxxxxxxxxxxx>

Da Lv (1):
drm: kirin: Fix for hikey620 display offset problem

John Stultz (4):
drm: kirin: Get rid of drmP.h includes
drm: kirin: Remove HISI_KIRIN_DW_DSI config option
drm: kirin: Remove unreachable return
drm: kirin: Move workqueue to ade_hw_ctx structure

Xu YiPing (21):
drm: kirin: Remove uncessary parameter indirection
drm: kirin: Remove out_format from ade_crtc
drm: kirin: Rename ade_plane to kirin_plane
drm: kirin: Rename ade_crtc to kirin_crtc
drm: kirin: Dynamically allocate the hw_ctx
drm: kirin: Move request irq handle in ade hw ctx alloc
drm: kirin: Move kirin_crtc, kirin_plane, kirin_format to
kirin_drm_drv.h
drm: kirin: Reanme dc_ops to kirin_drm_data
drm: kirin: Move ade crtc/plane help functions to driver_data
drm: kirin: Move channel formats to driver data
drm: kirin: Move mode config function to driver_data
drm: kirin: Move plane number and primay plane in driver data
drm: kirin: Move config max_width and max_height to driver data
drm: kirin: Move drm driver to driver data
drm: kirin: Add register connect helper functions in drm init
drm: kirin: Rename plane_init and crtc_init
drm: kirin: Fix dev->driver_data setting
drm: kirin: Make driver_data variable non-global
drm: kirin: Add alloc_hw_ctx/clean_hw_ctx ops in driver data
drm: kirin: Pass driver data to crtc init and plane init
drm: kirin: Move ade drm init to kirin drm drv

drivers/gpu/drm/hisilicon/kirin/Kconfig | 10 +-
drivers/gpu/drm/hisilicon/kirin/Makefile | 4 +-
.../gpu/drm/hisilicon/kirin/kirin_ade_reg.h | 1 +
.../gpu/drm/hisilicon/kirin/kirin_drm_ade.c | 360 +++++++-----------
.../gpu/drm/hisilicon/kirin/kirin_drm_drv.c | 257 +++++++++----
.../gpu/drm/hisilicon/kirin/kirin_drm_drv.h | 48 ++-
6 files changed, 379 insertions(+), 301 deletions(-)

--
2.17.1