Re: [PATCH] fix __percpu annotation in asm-generic
From: Christopher Lameter
Date: Fri Nov 29 2019 - 13:12:02 EST
On Wed, 27 Nov 2019, Luc Van Oostenryck wrote:
> 1) it would strip any address space, not just __percpu, so:
> it would need to be combined with __verify_pcpu_ptr() or,
> * a better name should be used,
typeof_cast_kernel() to express the fact that it creates a kernel pointer
and ignored the attributes??
> * it should be defined in a generic header, any idea where?
include/linux/compiler-types.h
> 2) while I find the current solution:
> typeof(T) __kernel __force *ptr = ...;
It would be
typeof_cast_kernel(&T) *xx = xxx
or so?