Re: [GIT PULL] treewide conversion to sizeof_member() for v5.5-rc1

From: Linus Torvalds
Date: Sun Dec 08 2019 - 18:20:02 EST

On Sat, Dec 7, 2019 at 11:48 AM Kees Cook <keescook@xxxxxxxxxxxx> wrote:
> Please pull this mostly mechanical treewide conversion to the single and
> more accurately named sizeof_member() macro for the end of v5.5-rc1.

So this one I'm _still_ not convinced about. It makes yet another name
for something we've had before, which just annoys me. And maybe it's
the 13-year old in me, but "sizeof_member()" just makes me go "that's

I _can_ see why we'd want to standardize on one of the tree versions
we have, but I can't really see the problem with the existing #define
that we have, and that is used (admittedly not all that much):