Re: [GIT PULL] treewide conversion to sizeof_member() for v5.5-rc1

From: Linus Torvalds
Date: Sun Dec 08 2019 - 18:54:14 EST

On Sun, Dec 8, 2019 at 3:40 PM <joe@xxxxxxxxxxx> wrote:
> Call it what the standard calls it.

... or, you know, call it what the individual parts of a data
structure is called in computer science in general: fields.

That really is standard naming too, Joe. Just to quote Wikipedia

"A record (also called tuple or struct) is an aggregate data
structure. A record is a value that contains other values, typically
in fixed number and sequence and typically indexed by names. The
elements of records are usually called fields or members"


Do we name things by their C implementation, or by their generic CS
names? Sometimes one, sometimes the other.

But the fact is, "field" really isn't wrong AND IT IS WHAT WE ALREADY USE.

And last time I pointed out that at least according to a quick grep,
we use "field" a whole lot more than we use "member".

Possibly exactly because that's the typical generic name.