Re: [PATCH v2 3/3] media: vimc: deb: Add support for {RGB,BGR,GBR}888 bus formats on source pad

From: Shuah Khan
Date: Mon Mar 30 2020 - 15:46:27 EST


On 3/30/20 1:43 PM, Helen Koike wrote:
Hello,

On 3/26/20 7:06 PM, Shuah Khan wrote:
On 3/26/20 3:47 PM, NÃcolas F. R. A. Prado wrote:
Add support for RGB888_*, BGR888_* and GBR888_* media bus formats on
the source pad of debayer subdevices.

Co-developed-by: Vitor Massaru Iha <vitor@xxxxxxxxxxx>
Signed-off-by: Vitor Massaru Iha <vitor@xxxxxxxxxxx>
Signed-off-by: NÃcolas F. R. A. Prado <nfraprado@xxxxxxxxxxxxxx>
---

Changes in v2:
- Change commit message to reflect v2 changes
- Rename variables
- Fix array formatting
- Add vimc_deb_is_src_code_valid function
- Add other BGR888 and RGB888 formats to debayer source pad supported
ÂÂ formats

 drivers/media/platform/vimc/vimc-debayer.c | 61 +++++++++++++++++-----
 1 file changed, 49 insertions(+), 12 deletions(-)

diff --git a/drivers/media/platform/vimc/vimc-debayer.c b/drivers/media/platform/vimc/vimc-debayer.c
index baf6bf9f65b5..33a9bea770bc 100644
--- a/drivers/media/platform/vimc/vimc-debayer.c
+++ b/drivers/media/platform/vimc/vimc-debayer.c
@@ -51,6 +51,19 @@ static const struct v4l2_mbus_framefmt sink_fmt_default = {
ÂÂÂÂÂ .colorspace = V4L2_COLORSPACE_DEFAULT,
 };
 +static const u32 vimc_deb_src_mbus_codes[] = {
+ÂÂÂ MEDIA_BUS_FMT_GBR888_1X24,
+ÂÂÂ MEDIA_BUS_FMT_BGR888_1X24,
+ÂÂÂ MEDIA_BUS_FMT_BGR888_3X8,
+ÂÂÂ MEDIA_BUS_FMT_RGB888_1X24,
+ÂÂÂ MEDIA_BUS_FMT_RGB888_2X12_BE,
+ÂÂÂ MEDIA_BUS_FMT_RGB888_2X12_LE,
+ÂÂÂ MEDIA_BUS_FMT_RGB888_3X8,
+ÂÂÂ MEDIA_BUS_FMT_RGB888_1X7X4_SPWG,
+ÂÂÂ MEDIA_BUS_FMT_RGB888_1X7X4_JEIDA,
+ÂÂÂ MEDIA_BUS_FMT_RGB888_1X32_PADHI,
+};
+
 static const struct vimc_deb_pix_map vimc_deb_pix_map_list[] = {
ÂÂÂÂÂ {
ÂÂÂÂÂÂÂÂÂ .code = MEDIA_BUS_FMT_SBGGR8_1X8,
@@ -125,6 +138,17 @@ static const struct vimc_deb_pix_map *vimc_deb_pix_map_by_code(u32 code)
ÂÂÂÂÂ return NULL;
 }
 +static int vimc_deb_is_src_code_invalid(u32 code)
+{
+ÂÂÂ unsigned int i;
+
+ÂÂÂ for (i = 0; i < ARRAY_SIZE(vimc_deb_src_mbus_codes); i++)
+ÂÂÂÂÂÂÂ if (vimc_deb_src_mbus_codes[i] == code)
+ÂÂÂÂÂÂÂÂÂÂÂ return 0;
+
+ÂÂÂ return -EINVAL;
+}

The naming is a bit confusing, since it checks if it is invalid, but returns a negative number if so.

How about renaming to vimc_deb_src_code_is_valid ?

+
 static int vimc_deb_init_cfg(struct v4l2_subdev *sd,
ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂ struct v4l2_subdev_pad_config *cfg)
 {
@@ -148,14 +172,11 @@ static int vimc_deb_enum_mbus_code(struct v4l2_subdev *sd,
ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂ struct v4l2_subdev_pad_config *cfg,
ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂ struct v4l2_subdev_mbus_code_enum *code)
 {
-ÂÂÂ /* We only support one format for source pads */
ÂÂÂÂÂ if (VIMC_IS_SRC(code->pad)) {
-ÂÂÂÂÂÂÂ struct vimc_deb_device *vdeb = v4l2_get_subdevdata(sd);
-
-ÂÂÂÂÂÂÂ if (code->index)
+ÂÂÂÂÂÂÂ if (code->index >= ARRAY_SIZE(vimc_deb_src_mbus_codes))
ÂÂÂÂÂÂÂÂÂÂÂÂÂ return -EINVAL;
 - code->code = vdeb->src_code;
+ÂÂÂÂÂÂÂ code->code = vimc_deb_src_mbus_codes[code->index];
ÂÂÂÂÂ } else {
ÂÂÂÂÂÂÂÂÂ if (code->index >= ARRAY_SIZE(vimc_deb_pix_map_list))
ÂÂÂÂÂÂÂÂÂÂÂÂÂ return -EINVAL;
@@ -170,8 +191,6 @@ static int vimc_deb_enum_frame_size(struct v4l2_subdev *sd,
ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂ struct v4l2_subdev_pad_config *cfg,
ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂ struct v4l2_subdev_frame_size_enum *fse)
 {
-ÂÂÂ struct vimc_deb_device *vdeb = v4l2_get_subdevdata(sd);
-
ÂÂÂÂÂ if (fse->index)
ÂÂÂÂÂÂÂÂÂ return -EINVAL;
 @@ -181,7 +200,7 @@ static int vimc_deb_enum_frame_size(struct v4l2_subdev *sd,
 Â if (!vpix)
ÂÂÂÂÂÂÂÂÂÂÂÂÂ return -EINVAL;
-ÂÂÂ } else if (fse->code != vdeb->src_code) {
+ÂÂÂ } else if (vimc_deb_is_src_code_invalid(fse->code)) {
ÂÂÂÂÂÂÂÂÂ return -EINVAL;
ÂÂÂÂÂ }
 @@ -237,6 +256,7 @@ static int vimc_deb_set_fmt(struct v4l2_subdev *sd,
 {
ÂÂÂÂÂ struct vimc_deb_device *vdeb = v4l2_get_subdevdata(sd);
ÂÂÂÂÂ struct v4l2_mbus_framefmt *sink_fmt;
+ÂÂÂ u32 *src_code;
 Â if (fmt->which == V4L2_SUBDEV_FORMAT_ACTIVE) {
ÂÂÂÂÂÂÂÂÂ /* Do not change the format while stream is on */
@@ -244,8 +264,10 @@ static int vimc_deb_set_fmt(struct v4l2_subdev *sd,
ÂÂÂÂÂÂÂÂÂÂÂÂÂ return -EBUSY;
 Â sink_fmt = &vdeb->sink_fmt;
+ÂÂÂÂÂÂÂ src_code = &vdeb->src_code;
ÂÂÂÂÂ } else {
ÂÂÂÂÂÂÂÂÂ sink_fmt = v4l2_subdev_get_try_format(sd, cfg, 0);
+ÂÂÂÂÂÂÂ src_code = &v4l2_subdev_get_try_format(sd, cfg, 1)->code;
ÂÂÂÂÂ }
 Â /*
@@ -253,9 +275,14 @@ static int vimc_deb_set_fmt(struct v4l2_subdev *sd,
ÂÂÂÂÂÂ * it is propagated from the sink
ÂÂÂÂÂÂ */
ÂÂÂÂÂ if (VIMC_IS_SRC(fmt->pad)) {
+ÂÂÂÂÂÂÂ u32 code = fmt->format.code;
+
ÂÂÂÂÂÂÂÂÂ fmt->format = *sink_fmt;
-ÂÂÂÂÂÂÂ /* TODO: Add support for other formats */
-ÂÂÂÂÂÂÂ fmt->format.code = vdeb->src_code;
+
+ÂÂÂÂÂÂÂ if (!vimc_deb_is_src_code_invalid(code))
+ÂÂÂÂÂÂÂÂÂÂÂ *src_code = code;
+
+ÂÂÂÂÂÂÂ fmt->format.code = *src_code;
ÂÂÂÂÂ } else {
ÂÂÂÂÂÂÂÂÂ /* Set the new format in the sink pad */
ÂÂÂÂÂÂÂÂÂ vimc_deb_adjust_sink_fmt(&fmt->format);
@@ -291,11 +318,21 @@ static void vimc_deb_set_rgb_mbus_fmt_rgb888_1x24(struct vimc_deb_device *vdeb,
ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂ unsigned int col,
ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂ unsigned int rgb[3])

Change this to pass a pointer and size.

Hi Shuah,

Modifying vimc_deb_set_rgb_mbus_fmt_rgb888_1x24() is not part of this patch, or do you mean another part of the code?


I know it isn't part of this patch. However, this could use improvment
and pass pointer and size.

Can be handled as a separate patch.

thanks,
-- Shuah