Re: [PATCH v3 1/5] arch/x86/kvm: Refactor l1d flush lifecycle management
From: Thomas Gleixner
Date: Fri Apr 17 2020 - 08:57:18 EST
Balbir Singh <sblbir@xxxxxxxxxx> writes:
> #include <asm-generic/cacheflush.h>
> #include <asm/special_insns.h>
>
> +#define L1D_CACHE_ORDER 4
Newline between constants and declarations please
> void clflush_cache_range(void *addr, unsigned int size);
> +void *alloc_l1d_flush_pages(void);
> +void cleanup_l1d_flush_pages(void *l1d_flush_pages);
Can we please have a consistent name space prefix?
l1d_flush_*()
Thanks,
tglx