@@ -1477,7 +1477,10 @@ static long fastrpc_device_ioctl(struct file *file, unsigned int cmd,
err = fastrpc_invoke(fl, argp);
break;
case FASTRPC_IOCTL_INIT_ATTACH:
- err = fastrpc_init_attach(fl);
+ err = fastrpc_init_attach(fl, 0);
+ break;
+ case FASTRPC_IOCTL_INIT_ATTACH_SNS:
+ err = fastrpc_init_attach(fl, 2);
Shouldn't you have #defines for those magic numbers somewhere? What
does 0 and 2 mean?
This is based off a downstream driver which also uses magic numbers, although I can make an educated guess about the meaning.
Srini do you have any suggestions for how to name these values?