Re: [PATCH] mm,oom_kill: fix the comment of is_dump_unreclaim_slabs()

From: Michal Hocko
Date: Tue Oct 27 2020 - 03:11:31 EST


On Sat 26-09-20 12:15:26, Hui Su wrote:
> fix the comment of is_dump_unreclaim_slabs(), it just check
> whether nr_unreclaimable slabs amount is greater than user
> memory.

The original comment is meant to say when the function should be used.
Your update makes the comment makes it a kerneldoc for an internal
function which on its own is not very useful. It is quite clear what
the function does. The intention is not clear anymore though.

If you find the comment confusing, however, then I would just propose either
dropping it altogether or rename it to should_dump_unreclaimable_slab.
Which is quite mouthful TBH.

> Signed-off-by: Hui Su <sh_def@xxxxxxx>
> ---
> mm/oom_kill.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/mm/oom_kill.c b/mm/oom_kill.c
> index e90f25d6385d..a4a47559abcd 100644
> --- a/mm/oom_kill.c
> +++ b/mm/oom_kill.c
> @@ -168,9 +168,9 @@ static bool oom_unkillable_task(struct task_struct *p)
> return false;
> }
>
> -/*
> - * Print out unreclaimble slabs info when unreclaimable slabs amount is greater
> - * than all user memory (LRU pages)
> +/**
> + * Check whether unreclaimable slabs amount is greater than
> + * all user memory(LRU pages).
> */
> static bool is_dump_unreclaim_slabs(void)
> {
> --
> 2.25.1
>
>

--
Michal Hocko
SUSE Labs