Re: [PATCH] drm/panel: Update BOE and INX initial code

From: Doug Anderson
Date: Tue Nov 30 2021 - 17:32:00 EST


Hi,

On Mon, Nov 22, 2021 at 11:52 PM yangcong
<yangcong5@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx> wrote:
>
> At present, we have enough panel to confirm the effect,
> update the initial code to achieve the best effect.
> such as gamma, Gtp timing. They are all minor modifications
> and doesn't affect the lighting of the panel.
>
> a)Boe panel Optimized touch horizontal grain.
> b)Inx panel Optimized GOP timming and gamma.

s/timming/timing


> Signed-off-by: yangcong <yangcong5@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
> ---
> .../gpu/drm/panel/panel-boe-tv101wum-nl6.c | 108 ++++++++++++------
> 1 file changed, 71 insertions(+), 37 deletions(-)

Please resend and include the panel model in "${SUBJECT}". Right now
your subject makes it sound as if this affects _all_ BOE and INX
panels but it only affects two particular ones.


> @@ -111,18 +111,16 @@ static const struct panel_init_cmd boe_tv110c9m_init_cmd[] = {
> _INIT_DCS_CMD(0xB0, 0x00, 0x00, 0x00, 0x1B, 0x00, 0x45, 0x00, 0x65, 0x00, 0x81, 0x00, 0x99, 0x00, 0xAE, 0x00, 0xC1),
> _INIT_DCS_CMD(0xB1, 0x00, 0xD2, 0x01, 0x0B, 0x01, 0x34, 0x01, 0x76, 0x01, 0xA3, 0x01, 0xEF, 0x02, 0x27, 0x02, 0x29),
> _INIT_DCS_CMD(0xB2, 0x02, 0x5F, 0x02, 0x9E, 0x02, 0xC9, 0x03, 0x00, 0x03, 0x26, 0x03, 0x53, 0x03, 0x63, 0x03, 0x73),
> - _INIT_DCS_CMD(0xB3, 0x03, 0x86, 0x03, 0x9A, 0x03, 0xAF, 0x03, 0xDF, 0x03, 0xF5, 0x03, 0xF7),
> -
> + _INIT_DCS_CMD(0xB3, 0x03, 0x86, 0x03, 0x9A, 0x03, 0xA7, 0x03, 0xCF, 0x03, 0xDE, 0x03, 0xE0),

You would know better than I would, but it seems like you've randomly
added / removed some blank lines in this patch. Since these are
totally opaque to me (which I hate) I don't know which is better or
worse, but it seems rather arbitrary to be messing with the spacing.


> @@ -428,10 +452,10 @@ static const struct panel_init_cmd inx_init_cmd[] = {

I should have noticed before, but the name "inx_init_cmd" is way too
generic. Can you also include a patch to rename this to
"inx_hj110iz_init_cmd" ?


Other than nits then I guess this is fine. I'll probably wait about a
week from whenever you send the next version and then plan to land it
in drm-misc-next barring any other feedback.

-Doug