[PATCH v8 2/6] iommu/tegra-smmu: Rename tegra_smmu_find_group to tegra_smmu_find_group_soc

From: Nicolin Chen
Date: Thu Dec 09 2021 - 02:38:47 EST


The existing function tegra_smmu_find_group really finds group->soc
pointer, so naming it "find_group" might not be clear by looking at
it alone. This patch renames it to tegra_smmu_group_soc in order to
disambiguate the use of "group" in this driver.

Signed-off-by: Nicolin Chen <nicolinc@xxxxxxxxxx>
---
drivers/iommu/tegra-smmu.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/iommu/tegra-smmu.c b/drivers/iommu/tegra-smmu.c
index fd9ef08cb7d9..5628865c04b0 100644
--- a/drivers/iommu/tegra-smmu.c
+++ b/drivers/iommu/tegra-smmu.c
@@ -872,7 +872,7 @@ static struct iommu_device *tegra_smmu_probe_device(struct device *dev)
static void tegra_smmu_release_device(struct device *dev) {}

static const struct tegra_smmu_group_soc *
-tegra_smmu_find_group(struct tegra_smmu *smmu, unsigned int swgroup)
+tegra_smmu_find_group_soc(struct tegra_smmu *smmu, unsigned int swgroup)
{
unsigned int i, j;

@@ -904,7 +904,7 @@ static struct iommu_group *tegra_smmu_device_group(struct device *dev)
struct iommu_group *grp;

/* Find group_soc associating with swgroup */
- soc = tegra_smmu_find_group(smmu, swgroup);
+ soc = tegra_smmu_find_group_soc(smmu, swgroup);

mutex_lock(&smmu->lock);

--
2.17.1