Re: [PATCH v2 0/5] lib/find: add find_nth_bit()
From: Andy Shevchenko
Date: Tue Jul 12 2022 - 14:29:22 EST
On Tue, Jul 12, 2022 at 6:26 PM Yury Norov <yury.norov@xxxxxxxxx> wrote:
> On Mon, Jul 11, 2022 at 1:55 AM Andy Shevchenko
> <andy.shevchenko@xxxxxxxxx> wrote:
> > On Mon, Jul 11, 2022 at 6:51 AM Yury Norov <yury.norov@xxxxxxxxx> wrote:
> > 2) fns() is not good abbreviation, because among ffs (First) and fls
> > (Last), fns would be read as Next, which is misleading, I'm not sure
> > fnths(), which is correct, is good for readers.
> I agree that fns() may be confusing, but fnths() is even worse to me.
I also think it's not the best choice.
> I expect that it will be mostly used indirectly via find_nth_bit(), and
> will not create a lot of confusion for users.
Perhaps in that case we can survive with something else? Naming is hard...
With Best Regards,