Re: [PATCH v2 0/5] lib/find: add find_nth_bit()
From: Yury Norov
Date: Tue Jul 12 2022 - 21:46:40 EST
On Tue, Jul 12, 2022 at 08:28:42PM +0200, Andy Shevchenko wrote:
> On Tue, Jul 12, 2022 at 6:26 PM Yury Norov <yury.norov@xxxxxxxxx> wrote:
> > On Mon, Jul 11, 2022 at 1:55 AM Andy Shevchenko
> > <andy.shevchenko@xxxxxxxxx> wrote:
> > > On Mon, Jul 11, 2022 at 6:51 AM Yury Norov <yury.norov@xxxxxxxxx> wrote:
> > > 2) fns() is not good abbreviation, because among ffs (First) and fls
> > > (Last), fns would be read as Next, which is misleading, I'm not sure
> > > fnths(), which is correct, is good for readers.
> > I agree that fns() may be confusing, but fnths() is even worse to me.
> I also think it's not the best choice.
> > I expect that it will be mostly used indirectly via find_nth_bit(), and
> > will not create a lot of confusion for users.
> Perhaps in that case we can survive with something else? Naming is hard...
OK, I'll move it to find.h and call __find_nth_bit().
Is this the only issue, or I'd wait for more comments?