Re: [PATCH] tty: gdm724x: Fix coding style checkpatch warnings

From: Dan Carpenter
Date: Fri Oct 13 2023 - 04:53:44 EST


On Thu, Oct 12, 2023 at 10:14:58PM -0700, Soumya Negi wrote:
> @@ -271,8 +272,8 @@ int register_lte_tty_driver(void)
> int ret;
>
> for (i = 0; i < TTY_MAX_COUNT; i++) {
> - tty_driver = tty_alloc_driver(GDM_TTY_MINOR,
> - TTY_DRIVER_REAL_RAW | TTY_DRIVER_DYNAMIC_DEV);
> + tty_driver = tty_alloc_driver(GDM_TTY_MINOR, TTY_DRIVER_REAL_RAW |
> + TTY_DRIVER_DYNAMIC_DEV);

Don't do this. The code was better before. The parameter
"TTY_DRIVER_REAL_RAW | TTY_DRIVER_DYNAMIC_DEV" is one thing and
splitting it up like that makes the code less readable. And I bet they
had to indent it like that to get under the 80 character limit.

This is an example of checkpatch giving bad advice.

regards,
dan carpenter