Re: [PATCH] tty: gdm724x: Fix coding style checkpatch warnings

From: Soumya Negi
Date: Fri Oct 13 2023 - 17:19:24 EST


On Fri, Oct 13, 2023 at 11:53:36AM +0300, Dan Carpenter wrote:
> On Thu, Oct 12, 2023 at 10:14:58PM -0700, Soumya Negi wrote:
> > @@ -271,8 +272,8 @@ int register_lte_tty_driver(void)
> > int ret;
> >
> > for (i = 0; i < TTY_MAX_COUNT; i++) {
> > - tty_driver = tty_alloc_driver(GDM_TTY_MINOR,
> > - TTY_DRIVER_REAL_RAW | TTY_DRIVER_DYNAMIC_DEV);
> > + tty_driver = tty_alloc_driver(GDM_TTY_MINOR, TTY_DRIVER_REAL_RAW |
> > + TTY_DRIVER_DYNAMIC_DEV);
>
> Don't do this. The code was better before. The parameter
> "TTY_DRIVER_REAL_RAW | TTY_DRIVER_DYNAMIC_DEV" is one thing and
> splitting it up like that makes the code less readable. And I bet they
> had to indent it like that to get under the 80 character limit.
>
> This is an example of checkpatch giving bad advice.

Hi Dan,

Will keep this in mind for other similar checkpatch warnings.

Thanks,
Soumya

> regards,
> dan carpenter
>