RE: [PATCH rdma-next 4/4] RDMA/mana_ib: Use struct mana_ib_queue for RAW QPs

From: Konstantin Taranov
Date: Mon Mar 18 2024 - 05:22:14 EST


> From: Long Li <longli@xxxxxxxxxxxxx>
> Sent: Friday, 15 March 2024 18:04
> To: Konstantin Taranov <kotaranov@xxxxxxxxxxxxxxxxxxx>; Konstantin
> Taranov <kotaranov@xxxxxxxxxxxxx>; sharmaajay@xxxxxxxxxxxxx;
> jgg@xxxxxxxx; leon@xxxxxxxxxx
> Cc: linux-rdma@xxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx
> Subject: RE: [PATCH rdma-next 4/4] RDMA/mana_ib: Use struct
> mana_ib_queue for RAW QPs
>
> > +struct mana_ib_raw_qp {
> > + /* Work queue info */
> > + struct mana_ib_queue queue;
> > + mana_handle_t tx_object;
> > +};
> > +
> > struct mana_ib_qp {
> > struct ib_qp ibqp;
> >
> > - /* Work queue info */
> > - struct ib_umem *sq_umem;
> > - int sqe;
> > - u64 sq_gdma_region;
> > - u64 sq_id;
> > - mana_handle_t tx_object;
> > + struct mana_ib_raw_qp sq;
>
> What's the naming scheme for RC? Maybe use raw_sq here?

The plan is to use struct mana_ib_rc_qp for RC QP.
But I think mana_ib_raw_sq is a good proposal for RAW packets. I will make it in v2.
Thanks!