Re: [PATCH v1] pwm: dwc: allow suspend/resume for 16 channels

From: Uwe Kleine-König
Date: Fri Apr 12 2024 - 07:13:11 EST


Hello,

On Fri, Apr 12, 2024 at 11:38:12AM +0530, Raag Jadav wrote:
> diff --git a/drivers/pwm/pwm-dwc.h b/drivers/pwm/pwm-dwc.h
> index a8b074841ae8..c6e2df5a6122 100644
> --- a/drivers/pwm/pwm-dwc.h
> +++ b/drivers/pwm/pwm-dwc.h
> @@ -38,6 +38,12 @@ struct dwc_pwm_info {
> unsigned int size;
> };
>
> +struct dwc_pwm_drvdata {
> + const struct dwc_pwm_info *info;
> + void __iomem *io_base;

.io_base is only used during init time and so doesn't need to be tracked
in driver data.

Otherwise I (only slightly) dislike
> + struct dwc_pwm_drvdata *data;
because "data" is very generic. I'd call it ddata. But I don't feel
strong here. I'm happy if you change to "ddata" in v2, I will silently
apply anyhow if you prefer "data".

> + struct pwm_chip *chips[];
> +};
> +
> struct dwc_pwm_ctx {
> u32 cnt;
> u32 cnt2;

Best regards
Uwe

--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | https://www.pengutronix.de/ |

Attachment: signature.asc
Description: PGP signature