[PATCH] md: make md_flush_request() more readable

From: linan666
Date: Sat May 25 2024 - 07:03:29 EST


From: Li Nan <linan122@xxxxxxxxxx>

Setting bio to NULL and checking 'if(!bio)' is redundant and looks strange,
just consolidate them into one condition. There are no functional changes.

Signed-off-by: Li Nan <linan122@xxxxxxxxxx>
---
drivers/md/md.c | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/drivers/md/md.c b/drivers/md/md.c
index aff9118ff697..509e5638cea1 100644
--- a/drivers/md/md.c
+++ b/drivers/md/md.c
@@ -654,15 +654,12 @@ bool md_flush_request(struct mddev *mddev, struct bio *bio)
WARN_ON(percpu_ref_is_zero(&mddev->active_io));
percpu_ref_get(&mddev->active_io);
mddev->flush_bio = bio;
- bio = NULL;
- }
- spin_unlock_irq(&mddev->lock);
-
- if (!bio) {
+ spin_unlock_irq(&mddev->lock);
INIT_WORK(&mddev->flush_work, submit_flushes);
queue_work(md_wq, &mddev->flush_work);
} else {
/* flush was performed for some other bio while we waited. */
+ spin_unlock_irq(&mddev->lock);
if (bio->bi_iter.bi_size == 0)
/* an empty barrier - all done */
bio_endio(bio);
--
2.39.2