Re: [PATCH v2 2/3] mctp pcc: Allow PCC Data Type in MCTP resource.

From: Ratheesh Kannoth
Date: Tue May 28 2024 - 23:25:59 EST


On 2024-05-29 at 00:48:22, admiyo@xxxxxxxxxxxxxxxxxxxxxx (admiyo@xxxxxxxxxxxxxxxxxxxxxx) wrote:
> From: Adam Young <admiyo@xxxxxxxxxxxxxxxxxxx>
> --- a/drivers/acpi/acpica/rsaddr.c
> +++ b/drivers/acpi/acpica/rsaddr.c
> @@ -282,7 +282,7 @@ acpi_rs_get_address_common(struct acpi_resource *resource,
>
> /* Validate the Resource Type */
>
> - if ((address.resource_type > 2) && (address.resource_type < 0xC0)) {
> + if ((address.resource_type > 2) && (address.resource_type < 0xC0) && (address.resource_type != 10)) {
use macros or enums instead of hard coded numbers. That will improve code readability.

> return (FALSE);
> }
>
> --
> 2.34.1
>