Re: [PATCH v2 2/3] mctp pcc: Allow PCC Data Type in MCTP resource.

From: Adam Young
Date: Thu May 30 2024 - 12:25:22 EST



On 5/28/24 23:25, Ratheesh Kannoth wrote:
On 2024-05-29 at 00:48:22, admiyo@xxxxxxxxxxxxxxxxxxxxxx (admiyo@xxxxxxxxxxxxxxxxxxxxxx) wrote:
From: Adam Young <admiyo@xxxxxxxxxxxxxxxxxxx>
--- a/drivers/acpi/acpica/rsaddr.c
+++ b/drivers/acpi/acpica/rsaddr.c
@@ -282,7 +282,7 @@ acpi_rs_get_address_common(struct acpi_resource *resource,

/* Validate the Resource Type */

- if ((address.resource_type > 2) && (address.resource_type < 0xC0)) {
+ if ((address.resource_type > 2) && (address.resource_type < 0xC0) && (address.resource_type != 10)) {
use macros or enums instead of hard coded numbers. That will improve code readability.

In general I agree, but this code is generated  from ACPICA and will not be directly commited.  The corresponding patch to acpica has already merged. What you see here is what the code will look like post-process from ACPICA conversion.



return (FALSE);
}

--
2.34.1