Re: [PATCHv11 05/19] x86/relocate_kernel: Use named labels for less confusion

From: Kirill A. Shutemov
Date: Wed May 29 2024 - 07:18:24 EST


On Wed, May 29, 2024 at 01:47:50PM +0300, Nikolay Borisov wrote:
>
>
> On 28.05.24 г. 12:55 ч., Kirill A. Shutemov wrote:
> > From: Borislav Petkov <bp@xxxxxxxxx>
> >
> > That identity_mapped() functions was loving that "1" label to the point
> > of completely confusing its readers.
> >
> > Use named labels in each place for clarity.
> >
> > No functional changes.
> >
> > Signed-off-by: Borislav Petkov (AMD) <bp@xxxxxxxxx>
> > Signed-off-by: Kirill A. Shutemov <kirill.shutemov@xxxxxxxxxxxxxxx>
> > ---
> > arch/x86/kernel/relocate_kernel_64.S | 13 +++++++------
> > 1 file changed, 7 insertions(+), 6 deletions(-)
> >
> > diff --git a/arch/x86/kernel/relocate_kernel_64.S b/arch/x86/kernel/relocate_kernel_64.S
> > index 56cab1bb25f5..085eef5c3904 100644
> > --- a/arch/x86/kernel/relocate_kernel_64.S
> > +++ b/arch/x86/kernel/relocate_kernel_64.S
> > @@ -148,9 +148,10 @@ SYM_CODE_START_LOCAL_NOALIGN(identity_mapped)
> > */
> > movl $X86_CR4_PAE, %eax
> > testq $X86_CR4_LA57, %r13
> > - jz 1f
> > + jz .Lno_la57
> > orl $X86_CR4_LA57, %eax
> > -1:
> > +.Lno_la57:
> > +
> > movq %rax, %cr4
> > jmp 1f
>
> That jmp 1f becomes redundant now as it simply jumps 1 line below.
>

Nothing changed wrt this jump. It dates back to initial kexec
implementation.

See 5234f5eb04ab ("[PATCH] kexec: x86_64 kexec implementation").

But I don't see functional need in it.

Anyway, it is outside of the scope of the patch.

--
Kiryl Shutsemau / Kirill A. Shutemov