Re: [PATCH v10 6/7] sched: Split out __schedule() deactivate task logic into a helper

From: Qais Yousef
Date: Tue Jun 04 2024 - 09:29:31 EST


On 05/06/24 21:54, John Stultz wrote:
> As we're going to re-use the deactivation logic,
> split it into a helper.
>
> Cc: Joel Fernandes <joelaf@xxxxxxxxxx>
> Cc: Qais Yousef <qyousef@xxxxxxxxxxx>
> Cc: Ingo Molnar <mingo@xxxxxxxxxx>
> Cc: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
> Cc: Juri Lelli <juri.lelli@xxxxxxxxxx>
> Cc: Vincent Guittot <vincent.guittot@xxxxxxxxxx>
> Cc: Dietmar Eggemann <dietmar.eggemann@xxxxxxx>
> Cc: Valentin Schneider <vschneid@xxxxxxxxxx>
> Cc: Steven Rostedt <rostedt@xxxxxxxxxxx>
> Cc: Ben Segall <bsegall@xxxxxxxxxx>
> Cc: Zimuzo Ezeozue <zezeozue@xxxxxxxxxx>
> Cc: Youssef Esmat <youssefesmat@xxxxxxxxxx>
> Cc: Mel Gorman <mgorman@xxxxxxx>
> Cc: Daniel Bristot de Oliveira <bristot@xxxxxxxxxx>
> Cc: Will Deacon <will@xxxxxxxxxx>
> Cc: Waiman Long <longman@xxxxxxxxxx>
> Cc: Boqun Feng <boqun.feng@xxxxxxxxx>
> Cc: "Paul E. McKenney" <paulmck@xxxxxxxxxx>
> Cc: Metin Kaya <Metin.Kaya@xxxxxxx>
> Cc: Xuewen Yan <xuewen.yan94@xxxxxxxxx>
> Cc: K Prateek Nayak <kprateek.nayak@xxxxxxx>
> Cc: Thomas Gleixner <tglx@xxxxxxxxxxxxx>
> Cc: kernel-team@xxxxxxxxxxx
> Tested-by: K Prateek Nayak <kprateek.nayak@xxxxxxx>
> Tested-by: Metin Kaya <metin.kaya@xxxxxxx>
> Reviewed-by: Metin Kaya <metin.kaya@xxxxxxx>
> Signed-off-by: John Stultz <jstultz@xxxxxxxxxx>
> ---
> v6:
> * Define function as static to avoid "no previous prototype"
> warnings as Reported-by: kernel test robot <lkp@xxxxxxxxx>
> v7:
> * Rename state task_state to be more clear, as suggested by
> Metin Kaya
> ---
> kernel/sched/core.c | 72 +++++++++++++++++++++++++++------------------
> 1 file changed, 43 insertions(+), 29 deletions(-)
>
> diff --git a/kernel/sched/core.c b/kernel/sched/core.c
> index 48f0d4b381d5..8bc5844ebab9 100644
> --- a/kernel/sched/core.c
> +++ b/kernel/sched/core.c
> @@ -6572,6 +6572,48 @@ pick_next_task(struct rq *rq, struct task_struct *prev, struct rq_flags *rf)
> # define SM_MASK_PREEMPT SM_PREEMPT
> #endif
>
> +/*
> + * Helper function for __schedule()
> + *
> + * If a task does not have signals pending, deactivate it and return true
> + * Otherwise marks the task's __state as RUNNING and returns false
> + */
> +static bool try_to_deactivate_task(struct rq *rq, struct task_struct *p,
> + unsigned long task_state)
> +{
> + if (signal_pending_state(task_state, p)) {
> + WRITE_ONCE(p->__state, TASK_RUNNING);

We can avoid extra indention for the other (lengthy) leg if we return here?

The return value is ignored for now, I don't mind keeping it but better call it
out in the commit message or when you add the new user later you can update the
signature more easily.

Generally I think patches 4, 5 and 6 could be sent as their own series with
minor commit messages tweaks to make them more independent and I hope Ingo and
Peter are okay to pick them up as they look a nice clean up in general.

Anyway:

Reviewed-by: Qais Yousef <qyousef@xxxxxxxxxxx>

> + } else {
> + p->sched_contributes_to_load =
> + (task_state & TASK_UNINTERRUPTIBLE) &&
> + !(task_state & TASK_NOLOAD) &&
> + !(task_state & TASK_FROZEN);
> +
> + if (p->sched_contributes_to_load)
> + rq->nr_uninterruptible++;
> +
> + /*
> + * __schedule() ttwu()
> + * prev_state = prev->state; if (p->on_rq && ...)
> + * if (prev_state) goto out;
> + * p->on_rq = 0; smp_acquire__after_ctrl_dep();
> + * p->state = TASK_WAKING
> + *
> + * Where __schedule() and ttwu() have matching control dependencies.
> + *
> + * After this, schedule() must not care about p->state any more.
> + */
> + deactivate_task(rq, p, DEQUEUE_SLEEP | DEQUEUE_NOCLOCK);
> +
> + if (p->in_iowait) {
> + atomic_inc(&rq->nr_iowait);
> + delayacct_blkio_start();
> + }
> + return true;
> + }
> + return false;
> +}
> +
> /*
> * __schedule() is the main scheduler function.
> *
> @@ -6665,35 +6707,7 @@ static void __sched notrace __schedule(unsigned int sched_mode)
> */
> prev_state = READ_ONCE(prev->__state);
> if (!(sched_mode & SM_MASK_PREEMPT) && prev_state) {
> - if (signal_pending_state(prev_state, prev)) {
> - WRITE_ONCE(prev->__state, TASK_RUNNING);
> - } else {
> - prev->sched_contributes_to_load =
> - (prev_state & TASK_UNINTERRUPTIBLE) &&
> - !(prev_state & TASK_NOLOAD) &&
> - !(prev_state & TASK_FROZEN);
> -
> - if (prev->sched_contributes_to_load)
> - rq->nr_uninterruptible++;
> -
> - /*
> - * __schedule() ttwu()
> - * prev_state = prev->state; if (p->on_rq && ...)
> - * if (prev_state) goto out;
> - * p->on_rq = 0; smp_acquire__after_ctrl_dep();
> - * p->state = TASK_WAKING
> - *
> - * Where __schedule() and ttwu() have matching control dependencies.
> - *
> - * After this, schedule() must not care about p->state any more.
> - */
> - deactivate_task(rq, prev, DEQUEUE_SLEEP | DEQUEUE_NOCLOCK);
> -
> - if (prev->in_iowait) {
> - atomic_inc(&rq->nr_iowait);
> - delayacct_blkio_start();
> - }
> - }
> + try_to_deactivate_task(rq, prev, prev_state);
> switch_count = &prev->nvcsw;
> }
>
> --
> 2.45.0.rc1.225.g2a3ae87e7f-goog
>