Re: [PATCH 3/3] rust: sync: Add IrqSpinLock

From: Peter Zijlstra
Date: Fri Jul 26 2024 - 16:26:44 EST


On Fri, Jul 26, 2024 at 04:21:09PM -0400, Lyude Paul wrote:
> On Fri, 2024-07-26 at 09:48 +0200, Peter Zijlstra wrote:
> > On Thu, Jul 25, 2024 at 06:27:52PM -0400, Lyude Paul wrote:
> > > A variant of SpinLock that is expected to be used in noirq contexts, and
> > > thus requires that the user provide an kernel::irq::IrqDisabled to prove
> > > they are in such a context upon lock acquisition. This is the rust
> > > equivalent of spin_lock_irqsave()/spin_lock_irqrestore().
> >
> > So aside from the horrendous camel-case thing, why are you naming this
>
> Also - sorry I didn't notice this comment before, but I wanted to respond
> since it seems like you may not be aware: camel case is mandated as part of
> the rust standard:
>
> https://rust-lang.github.io/api-guidelines/naming.html
>
> Of course the kernel has its own coding standards that we need to conform to
> within reason! But if we tried to ignore camel casing for rust code we'd end
> up with rust code where everything would be mixed between types from core
> being camel cased and types from kernel crates not being camel cased.

Yeah, I'm aware, it is one of the very many reasons I find it very very
hard to like Rust :/