RE: [PATCH v2] scsi: ufs: Zero utp_upiu_req at the beginning of each command

From: Avri Altman
Date: Wed Sep 18 2024 - 02:03:42 EST


> On 9/16/24 11:52 PM, Avri Altman wrote:
> > Is the below proposal evidently better? e.g. with respect of
> > efficiency, simplicity, readability etc.?
>
> The approach I proposed has two advantages:
> * All code that initializes *lrbp->ucd_req_ptr occurs in the same function. I think
> that is a significant advantage with regard to maintainability.
> * ucd_req_ptr->header is initialized once instead of twice. Hence the approach I
> proposed is more efficient.
Sorry, not being stubborn or anything, I might be mis-reading your proposal.

My proposal is making 4 changes, attending the 5 upiu types:
1) Zero query upiu and nop upiu in ufshcd_compose_devman_upiu
2) zero command upiu in ufshcd_comp_scsi_upiu
3) zero raw query upiu in ufshcd_issue_devman_upiu_cmd, and
4) zero rpmb extended header (raw command upiu) in ufshcd_advanced_rpmb_req_handler

Your proposal is making 3 changes:
- zero query upiu in ufshcd_prepare_utp_query_req_upiu
- zero nop upiu in ufshcd_prepare_utp_nop_upiu
- zero command upiu in ufshcd_prepare_utp_scsi_cmd_upiu
And you haven't zero the raw query upiu nor the rpmb extended header .

What am I missing?

Thanks,
Avri
>
> Thanks,
>
> Bart.