Re: [PATCH v4 1/9] i2c: riic: Introduce a separate variable for IRQ
From: Geert Uytterhoeven
Date: Fri Jan 03 2025 - 05:48:21 EST
Hi Prabhakar,
Thanks for your patch!
On Fri, Jan 3, 2025 at 10:19 AM Prabhakar <prabhakar.csengg@xxxxxxxxx> wrote:
> From: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx>
>
> Refactor the IRQ handling in riic_i2c_probe by introducing a local variable
> `irq` to store IRQ numbers instead of assigning them to `ret`. This change
> improves code readability and clarity.
>
> Remove explicit error handling after `platform_get_irq()` since
> `devm_request_irq()` already handles such errors.
Where does it handle such errors?
I only found the following check in request_threaded_irq():
desc = irq_to_desc(irq);
if (!desc)
return -EINVAL;
Although irq_to_desc() takes an unsigned int, it should indeed catch
invalid (negative) interrupt numbers, but the code above would not
propagate the correct error code (e.g. -EPROBE_DEFER).
> Suggested-by: Andy Shevchenko <andy.shevchenko@xxxxxxxxx>
> Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@xxxxxxxxxxxxxx>
> --- a/drivers/i2c/busses/i2c-riic.c
> +++ b/drivers/i2c/busses/i2c-riic.c
> @@ -464,11 +464,9 @@ static int riic_i2c_probe(struct platform_device *pdev)
> return ret;
>
> for (i = 0; i < ARRAY_SIZE(riic_irqs); i++) {
> - ret = platform_get_irq(pdev, riic_irqs[i].res_num);
> - if (ret < 0)
> - return ret;
> + int irq = platform_get_irq(pdev, riic_irqs[i].res_num);
So I think you need to keep a check for irq < 0.
>
> - ret = devm_request_irq(dev, ret, riic_irqs[i].isr,
> + ret = devm_request_irq(dev, irq, riic_irqs[i].isr,
> 0, riic_irqs[i].name, riic);
> if (ret) {
> dev_err(dev, "failed to request irq %s\n", riic_irqs[i].name);
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds