On Wed, Jan 15, 2025 at 10:55:22AM +0100, Jonas Andreasson wrote:
+ if (!data || data->range == -1)
+ goto fallback;
...
+ return selector;
+
+fallback:
+ return regulator_map_voltage_pickable_linear_range(rdev, min_uV, max_uV);
You could just have the return statement directly and avoid the goto
which would make this easier to follow.