Re: Rust kernel policy

From: Bartosz Golaszewski
Date: Wed Feb 19 2025 - 09:51:41 EST


On Wed, 19 Feb 2025 at 15:47, Martin K. Petersen
<martin.petersen@xxxxxxxxxx> wrote:
>
>
> James,
>
> > Could we possibly fix a lot of this by adopting the _cleanup_
> > annotations[1]? I've been working in systemd code recently and they
> > seem to make great use of this for error leg simplification.
>
> We already have this:
>
> include/linux/cleanup.h
>
> I like using cleanup attributes for some error handling. However, I'm
> finding that in many cases I want to do a bit more than a simple
> kfree(). And at that point things get syntactically messy in the
> variable declarations and harder to read than just doing a classic goto
> style unwind.
>

The same header also introduced infrastructure for creating "classes"
which are useful if your "destructor" (or "constructor" and structure
definition for that matter) is more complex.

I find the lock guards from the same include very helpful in
simplifying error paths in critical sections.

Bartosz