Re: [PATCH 1/2] tty: serial: fsl_lpuart: Use u32 for register variables

From: Jiri Slaby
Date: Fri Mar 07 2025 - 02:25:44 EST


On 07. 03. 25, 3:25, Sherry Sun wrote:
Use u32 rather than unsigned long for register variables for clarity and
consistency.

Signed-off-by: Sherry Sun <sherry.sun@xxxxxxx>
---
drivers/tty/serial/fsl_lpuart.c | 54 ++++++++++++++++-----------------
1 file changed, 27 insertions(+), 27 deletions(-)

diff --git a/drivers/tty/serial/fsl_lpuart.c b/drivers/tty/serial/fsl_lpuart.c
index 4dc2f3e2b8e0..888d744494d6 100644
--- a/drivers/tty/serial/fsl_lpuart.c
+++ b/drivers/tty/serial/fsl_lpuart.c
@@ -450,7 +450,7 @@ static void lpuart_stop_tx(struct uart_port *port)
static void lpuart32_stop_tx(struct uart_port *port)
{
- unsigned long temp;
+ u32 temp;

This patch is fine per se. But could you also rename these temps to something sane? (In a separate patch.) Like ctrl in this case.

thanks,
--
js
suse labs