RE: [PATCH 1/2] tty: serial: fsl_lpuart: Use u32 for register variables
From: Sherry Sun
Date: Fri Mar 07 2025 - 03:02:33 EST
> -----Original Message-----
> From: Jiri Slaby <jirislaby@xxxxxxxxxx>
> Sent: Friday, March 7, 2025 3:26 PM
> To: Sherry Sun <sherry.sun@xxxxxxx>; gregkh@xxxxxxxxxxxxxxxxxxx
> Cc: linux-serial@xxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx;
> imx@xxxxxxxxxxxxxxx; Shenwei Wang <shenwei.wang@xxxxxxx>
> Subject: Re: [PATCH 1/2] tty: serial: fsl_lpuart: Use u32 for register variables
>
> On 07. 03. 25, 3:25, Sherry Sun wrote:
> > Use u32 rather than unsigned long for register variables for clarity
> > and consistency.
> >
> > Signed-off-by: Sherry Sun <sherry.sun@xxxxxxx>
> > ---
> > drivers/tty/serial/fsl_lpuart.c | 54 ++++++++++++++++-----------------
> > 1 file changed, 27 insertions(+), 27 deletions(-)
> >
> > diff --git a/drivers/tty/serial/fsl_lpuart.c
> > b/drivers/tty/serial/fsl_lpuart.c index 4dc2f3e2b8e0..888d744494d6
> > 100644
> > --- a/drivers/tty/serial/fsl_lpuart.c
> > +++ b/drivers/tty/serial/fsl_lpuart.c
> > @@ -450,7 +450,7 @@ static void lpuart_stop_tx(struct uart_port *port)
> >
> > static void lpuart32_stop_tx(struct uart_port *port)
> > {
> > - unsigned long temp;
> > + u32 temp;
>
> This patch is fine per se. But could you also rename these temps to
> something sane? (In a separate patch.) Like ctrl in this case.
>
Hi Jiri,
Sure, will make another patch to clean up these temp variable names.
Best Regards
Sherry