Re: [PATCH net-next v8 09/10] net: gianfar: Use device_get_child_node_count_named()

From: Matti Vaittinen
Date: Thu Mar 20 2025 - 02:12:31 EST


On 19/03/2025 18:07, Simon Horman wrote:
On Mon, Mar 17, 2025 at 05:52:25PM +0200, Matti Vaittinen wrote:
We can avoid open-coding the loop construct which counts firmware child
nodes with a specific name by using the newly added
device_get_child_node_count_named().

The gianfar driver has such open-coded loop. Replace it with the
device_get_child_node_count_named().

Suggested-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
Signed-off-by: Matti Vaittinen <mazziesaccount@xxxxxxxxx>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>

This patch looks good to me.
But I think it would be best to resubmit it,
as a standalone patch for net-next, once
it's dependencies are present in net-next.

Thanks Simon. I think you're right.