Re: [PATCH v3] mm/page_alloc: Consolidate unlikely handling in page_expected_state
From: Ye Liu
Date: Wed Mar 26 2025 - 05:34:38 EST
在 2025/3/26 16:48, Markus Elfring 写道:
>> Consolidates the handling of
> …
>> This change simplifies
> …
>> ---
>> V3: Delete 'This patch'.
> How good does such information fit to the wording requirement “imperative mood”?
> https://web.git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/submitting-patches.rst?h=v6.14#n94
How about this?
Consolidate the handling of unlikely conditions in the page_expected_state
function to reduce code duplication and improve readability.
Move the logic for handling __PG_HWPOISON flags from the check_new_page_bad
function to the page_expected_state function, and remove check_new_page_bad.
Call bad_page directly from the check_new_page function if the page has
unexpected flags.
Simplify the code by reducing the number of functions and centralizing the
handling of unlikely conditions.
> …
>> ---
>> ---
>> mm/page_alloc.c | 24 ++++++++----------------
> How do you think about to omit redundant marker lines?
--- delete this one?
---
mm/page_alloc.c | 24 ++++++++----------------
like this ?
V2: return true instead of false in the PageHWPoison branch.
---
mm/page_alloc.c | 24 ++++++++----------------
Thanks for pointing out the formatting issue.
I would like to get your approval on the above changes before I send patch v4.
> Regards,
> Markus