Re: [PATCH 2/2] rpmsg: glink_native: remove duplicate code for rpmsg device remove
From: Dmitry Baryshkov
Date: Fri Aug 22 2025 - 06:18:10 EST
On Fri, Aug 22, 2025 at 11:00:43AM +0100, srinivas.kandagatla@xxxxxxxxxxxxxxxx wrote:
> From: Srinivas Kandagatla <srinivas.kandagatla@xxxxxxxxxxxxxxxx>
>
> rpmsg device remove code is duplicated in at-least 2-3 places, add a
> helper function to remove this duplicated code.
I think it's better to sqiash this into the previous patch. Otherwise
you are fixing the code that you've just added.
>
> Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@xxxxxxxxxxxxxxxx>
> ---
> drivers/rpmsg/qcom_glink_native.c | 43 ++++++++++++-------------------
> 1 file changed, 16 insertions(+), 27 deletions(-)
>
--
With best wishes
Dmitry