Re: [PATCH 2/2] rpmsg: glink_native: remove duplicate code for rpmsg device remove
From: Srinivas Kandagatla
Date: Fri Aug 22 2025 - 06:20:28 EST
On 8/22/25 11:14 AM, Dmitry Baryshkov wrote:
> On Fri, Aug 22, 2025 at 11:00:43AM +0100, srinivas.kandagatla@xxxxxxxxxxxxxxxx wrote:
>> From: Srinivas Kandagatla <srinivas.kandagatla@xxxxxxxxxxxxxxxx>
>>
>> rpmsg device remove code is duplicated in at-least 2-3 places, add a
>> helper function to remove this duplicated code.
>
> I think it's better to sqiash this into the previous patch. Otherwise
> you are fixing the code that you've just added.
I did not wanted to add new cleanup code for backports, which is why I
split this up as fix and cleanup.
Am happy to merge these two if Bjorn prefers that way.
--srini
>
>>
>> Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@xxxxxxxxxxxxxxxx>
>> ---
>> drivers/rpmsg/qcom_glink_native.c | 43 ++++++++++++-------------------
>> 1 file changed, 16 insertions(+), 27 deletions(-)
>>