Re: [PATCH v3 2/4] dt-bindings: phy: qcom,qcs615-qmp-usb3-dp-phy: Add support for Shikra
From: Krishna Kurapati
Date: Mon Jun 15 2026 - 15:02:52 EST
On 5/27/2026 3:16 PM, Krzysztof Kozlowski wrote:
On Wed, May 27, 2026 at 12:13:59AM +0530, Pratham Pratap wrote:
From: Krishna Kurapati <krishna.kurapati@xxxxxxxxxxxxxxxx>
Declare the USB QMP Phy present on Shikra SoC. On this SoC, although
there are DP registers, the required internal pins have been removed
and hence DP wouldn't be operational.
Shikra needs 3 resets (dp/ phy/ phy_phy) to be asserted and de-asserted
as per hardware recommendation. Extend the bindings to accommodate the
additional reset.
Use QCS615 as a fallback since the software interface is compatible with
Shikra.
Signed-off-by: Krishna Kurapati <krishna.kurapati@xxxxxxxxxxxxxxxx>
Signed-off-by: Pratham Pratap <pratham.pratap@xxxxxxxxxxxxxxxx>
---
.../bindings/phy/qcom,qcs615-qmp-usb3dp-phy.yaml | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)
diff --git a/Documentation/devicetree/bindings/phy/qcom,qcs615-qmp-usb3dp-phy.yaml b/Documentation/devicetree/bindings/phy/qcom,qcs615-qmp-usb3dp-phy.yaml
index efb465c71c1b..65ae4c6e09db 100644
--- a/Documentation/devicetree/bindings/phy/qcom,qcs615-qmp-usb3dp-phy.yaml
+++ b/Documentation/devicetree/bindings/phy/qcom,qcs615-qmp-usb3dp-phy.yaml
@@ -16,8 +16,12 @@ description:
properties:
compatible:
- enum:
- - qcom,qcs615-qmp-usb3-dp-phy
+ oneOf:
+ - items:
+ - enum:
+ - qcom,shikra-qmp-usb3-dp-phy
+ - const: qcom,qcs615-qmp-usb3-dp-phy
+ - const: qcom,qcs615-qmp-usb3-dp-phy
reg:
maxItems: 1
@@ -33,12 +37,15 @@ properties:
- const: pipe
resets:
- maxItems: 2
+ minItems: 2
+ maxItems: 3
So QCS615 has three resets now? This needs to be explained in the commit
msg. Or fixed with constraints, see writing bindings.
Ok, will separate out for Shikra and keep only two for Talos.
The resets needed on Shikra are:reset-names:
+ minItems: 2
items:
- const: phy_phy
- const: dp_phy
+ - const: phy
Not phy_phy_phy? Joking aside, you already have a phy - "phy_phy" - so
this is not correct name. I don't know what is the correct name, though.
Please consult device manual.
GCC_USB3PHY_PHY_PRIM_SP0_BCR
GCC_USB3_DP_PHY_PRIM_BCR
GCC_USB3_PHY_PRIM_SP0_BCR
Hence named the third one as "phy".
Regards,
Krishna,