Re: [PATCH v2 6/6] mm/page_owner: drop redundant page_owner prefix from static symbols
From: Zi Yan
Date: Fri Jun 26 2026 - 14:56:16 EST
On Thu Jun 25, 2026 at 10:45 PM EDT, Ye Liu wrote:
> All of these symbols are file-scoped (static) in page_owner.c, so the
> page_owner_ prefix is pure noise. Rename them to shorter, still-clear
> names:
>
> page_owner_stack_op -> stack_op
> page_owner_stack_open -> stack_open
> page_owner_stack_fops -> stack_fops
> page_owner_pages_threshold -> pages_threshold
> page_owner_threshold_get -> threshold_get
> page_owner_threshold_set -> threshold_set
> page_owner_threshold_fops -> threshold_fops
>
> No functional change.
>
> Signed-off-by: Ye Liu <ye.liu@xxxxxxxxx>
> ---
> mm/page_owner.c | 35 +++++++++++++++++------------------
> 1 file changed, 17 insertions(+), 18 deletions(-)
>
The rename makes sense.
Acked-by: Zi Yan <ziy@xxxxxxxxxx>
--
Best Regards,
Yan, Zi