Re: [PATCH v2 6/6] mm/page_owner: drop redundant page_owner prefix from static symbols
From: Vlastimil Babka (SUSE)
Date: Mon Jun 29 2026 - 04:16:38 EST
On 6/26/26 04:45, Ye Liu wrote:
> All of these symbols are file-scoped (static) in page_owner.c, so the
> page_owner_ prefix is pure noise. Rename them to shorter, still-clear
> names:
>
> page_owner_stack_op -> stack_op
> page_owner_stack_open -> stack_open
> page_owner_stack_fops -> stack_fops
> page_owner_pages_threshold -> pages_threshold
> page_owner_threshold_get -> threshold_get
> page_owner_threshold_set -> threshold_set
> page_owner_threshold_fops -> threshold_fops
>
> No functional change.
>
> Signed-off-by: Ye Liu <ye.liu@xxxxxxxxx>
Reviewed-by: Vlastimil Babka (SUSE) <vbabka@xxxxxxxxxx>
Nit:
> -static int page_owner_threshold_set(void *data, u64 val)
> +static int threshold_set(void *data, u64 val)
> {
> - WRITE_ONCE(page_owner_pages_threshold, val);
> + WRITE_ONCE(pages_threshold, val);
> return 0;
> }
>
> -DEFINE_SIMPLE_ATTRIBUTE(page_owner_threshold_fops, &page_owner_threshold_get,
> - &page_owner_threshold_set, "%llu\n");
> -
> +DEFINE_SIMPLE_ATTRIBUTE(threshold_fops, &threshold_get,
> + &threshold_set, "%llu\n");
We can now do make it a single line? 82 characters are fine unless hch sees
this. checkpatch now warns on 100 chars
>
> static int __init pageowner_init(void)
> {
> @@ -999,17 +998,17 @@ static int __init pageowner_init(void)
> debugfs_create_file("show_stacks", 0400, dir,
> (void *)(STACK_PRINT_FLAG_STACK |
> STACK_PRINT_FLAG_PAGES),
> - &page_owner_stack_fops);
> + &stack_fops);
> debugfs_create_file("show_handles", 0400, dir,
> (void *)(STACK_PRINT_FLAG_HANDLE |
> STACK_PRINT_FLAG_PAGES),
> - &page_owner_stack_fops);
> + &stack_fops);
> debugfs_create_file("show_stacks_handles", 0400, dir,
> (void *)(STACK_PRINT_FLAG_STACK |
> STACK_PRINT_FLAG_HANDLE),
> - &page_owner_stack_fops);
> + &stack_fops);
> debugfs_create_file("count_threshold", 0600, dir, NULL,
> - &page_owner_threshold_fops);
> + &threshold_fops);
> return 0;
> }
> late_initcall(pageowner_init)