Re: [PATCH v3 2/4] clk: en7523: add support for dedicated PCIe PERSTOUT reset
From: Christian Marangi
Date: Mon Jun 29 2026 - 03:34:04 EST
On Mon, Jun 29, 2026 at 09:07:22AM +0200, Philipp Zabel wrote:
> On Sa, 2026-06-27 at 14:14 +0200, Christian Marangi wrote:
> > Add support for resetting the PCIe lines with the PERSTOUT reset. These
> > special reset are controlled by the PCIC register and are specific to each
> > of the 3 PCIe lines.
> >
> > Notice that reset logic is inverted for these bit where 0 is assert and 1
> > deassert. This is intenrally handled in the reset function.
> ^^
> typo: internally
>
Thanks!
> > PCI enable/disable are updated to drop PERSTOUT bits in favor dedicated
> > reset handling.
> >
> > Signed-off-by: Christian Marangi <ansuelsmth@xxxxxxxxx>
> > ---
> > drivers/clk/clk-en7523.c | 39 ++++++++++++++++++++++++++++-----------
> > 1 file changed, 28 insertions(+), 11 deletions(-)
> >
> > diff --git a/drivers/clk/clk-en7523.c b/drivers/clk/clk-en7523.c
> > index 1ab0e2eca5d3..c9b21d9bf2f3 100644
> > --- a/drivers/clk/clk-en7523.c
> > +++ b/drivers/clk/clk-en7523.c
> [...]
> > @@ -754,14 +756,21 @@ static int en7523_reset_update(struct reset_controller_dev *rcdev,
> > unsigned long id, bool assert)
> > {
> > struct en_rst_data *rst_data = container_of(rcdev, struct en_rst_data, rcdev);
> > - void __iomem *addr = rst_data->base + rst_data->bank_ofs[id / RST_NR_PER_BANK];
> > + u32 offset = rst_data->bank_ofs[id / RST_NR_PER_BANK];
> > + void __iomem *addr = rst_data->base + offset;
> > + bool inverted = false;
> > u32 val;
> >
> > + /* For PCIC reset logic is inverted, 0:assert 1:deassert*/
> > + if (offset == REG_NP_SCU_PCIC)
> > + inverted = true;
> > +
> > val = readl(addr);
> > + val &= ~BIT(id % RST_NR_PER_BANK);
> > if (assert)
> > - val |= BIT(id % RST_NR_PER_BANK);
> > + val |= inverted ? 0 : BIT(id % RST_NR_PER_BANK);
> > else
> > - val &= ~BIT(id % RST_NR_PER_BANK);
> > + val |= inverted ? BIT(id % RST_NR_PER_BANK) : 0;
>
> You can simplify this into a single (assert ^ inverted) condition.
>
Yep I know but I feel this would decrease readability of the logic. Do you
think it's worth it?
> regards
> Philipp
--
Ansuel