Re: [PATCH] ata: sata_dwc_460ex: use platform_get_irq()

From: Niklas Cassel

Date: Mon Jun 29 2026 - 04:28:04 EST


On Sun, Jun 28, 2026 at 04:03:10PM -0700, Rosen Penev wrote:
> Replace irq_of_parse_and_map() with platform_get_irq() in both
> sata_dwc_dma_init_old() and sata_dwc_probe(). This is the preferred
> way to obtain IRQs for platform devices and provides better error
> reporting. Remove the now-unnecessary #include <linux/of_irq.h>.
>
> irq_of_parse_and_map() requires irq_dispose_mapping(), which is missing.
>
> Assisted-by: opencode:big-pickle
> Signed-off-by: Rosen Penev <rosenp@xxxxxxxxx>
> ---

Reviewed-by: Niklas Cassel <cassel@xxxxxxxxxx>