Re: [PATCH] ata: sata_dwc_460ex: use platform_get_irq()
From: Damien Le Moal
Date: Mon Jun 29 2026 - 19:59:02 EST
On 6/29/26 08:03, Rosen Penev wrote:
> Replace irq_of_parse_and_map() with platform_get_irq() in both
> sata_dwc_dma_init_old() and sata_dwc_probe(). This is the preferred
> way to obtain IRQs for platform devices and provides better error
> reporting. Remove the now-unnecessary #include <linux/of_irq.h>.
>
> irq_of_parse_and_map() requires irq_dispose_mapping(), which is missing.
>
> Assisted-by: opencode:big-pickle
> Signed-off-by: Rosen Penev <rosenp@xxxxxxxxx>
Applied to for-7.2-fixes. Thanks!
--
Damien Le Moal
Western Digital Research