Re: [PATCH v8 07/10] rust: configfs: use `LocalModule` for `THIS_MODULE`
From: Gary Guo
Date: Mon Jul 13 2026 - 08:11:25 EST
On Mon Jul 13, 2026 at 7:45 AM BST, Alvin Sun wrote:
> Replace the `THIS_MODULE` static reference in the `configfs_attrs!`
> macro with `this_module::<LocalModule>()`, and update
> rnull to import `LocalModule` instead of `THIS_MODULE`, consistent
> with the move of `THIS_MODULE` into the `ModuleMetadata` trait.
>
> Assisted-by: opencode:glm-5.2
> Reviewed-by: Andreas Hindborg <a.hindborg@xxxxxxxxxx>
> Acked-by: Danilo Krummrich <dakr@xxxxxxxxxx>
> Signed-off-by: Alvin Sun <alvin.sun@xxxxxxxxx>
Reviewed-by: Gary Guo <gary@xxxxxxxxxxx>
> ---
> drivers/block/rnull/configfs.rs | 5 +----
> rust/kernel/configfs.rs | 9 ++++++---
> 2 files changed, 7 insertions(+), 7 deletions(-)