Re: [PATCH v8 07/10] rust: configfs: use `LocalModule` for `THIS_MODULE`

From: Andreas Hindborg

Date: Wed Jul 15 2026 - 02:49:22 EST


Alvin Sun <alvin.sun@xxxxxxxxx> writes:

> Replace the `THIS_MODULE` static reference in the `configfs_attrs!`
> macro with `this_module::<LocalModule>()`, and update
> rnull to import `LocalModule` instead of `THIS_MODULE`, consistent
> with the move of `THIS_MODULE` into the `ModuleMetadata` trait.
>
> Assisted-by: opencode:glm-5.2
> Reviewed-by: Andreas Hindborg <a.hindborg@xxxxxxxxxx>
> Acked-by: Danilo Krummrich <dakr@xxxxxxxxxx>
> Signed-off-by: Alvin Sun <alvin.sun@xxxxxxxxx>


Acked-by: Andreas Hindborg <a.hindborg@xxxxxxxxxx>

Best regards,
Andreas Hindborg