Re: [PATCH] dma-direct: Improve readability of the dma_direct_map_sg() for P2PDMA case

From: Logan Gunthorpe

Date: Mon Jul 13 2026 - 11:48:51 EST




On 2026-07-13 02:30, Marek Szyprowski wrote:
> Improve readability of the sg_dma_len assignment in the P2PDMA cases by
> removing duplicated code, which was a direct result of the d0d08f4bd7f6
> ("dma-direct: Fix missing sg_dma_len assignment in P2PDMA bus mappings")
> fix. No functional change.
>
> Suggested-by: Leon Romanovsky <leon@xxxxxxxxxx>
> Link: https://lore.kernel.org/all/20260604071856.GA245424@unreal/
> Signed-off-by: Marek Szyprowski <m.szyprowski@xxxxxxxxxxx>

Looks good to me, thanks.

Reviewed-by: Logan Gunthorpe <logang@xxxxxxxxxxxx>