Re: [PATCH] dma-direct: Improve readability of the dma_direct_map_sg() for P2PDMA case
From: Marek Szyprowski
Date: Tue Jul 14 2026 - 02:03:48 EST
On 13.07.2026 10:30, Marek Szyprowski wrote:
> Improve readability of the sg_dma_len assignment in the P2PDMA cases by
> removing duplicated code, which was a direct result of the d0d08f4bd7f6
> ("dma-direct: Fix missing sg_dma_len assignment in P2PDMA bus mappings")
> fix. No functional change.
>
> Suggested-by: Leon Romanovsky <leon@xxxxxxxxxx>
> Link: https://lore.kernel.org/all/20260604071856.GA245424@unreal/
> Signed-off-by: Marek Szyprowski <m.szyprowski@xxxxxxxxxxx>
Pushed to dma-mapping-for-next.
> ---
> kernel/dma/direct.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/kernel/dma/direct.c b/kernel/dma/direct.c
> index 4391b797d4db..d8219efe3273 100644
> --- a/kernel/dma/direct.c
> +++ b/kernel/dma/direct.c
> @@ -486,15 +486,14 @@ int dma_direct_map_sg(struct device *dev, struct scatterlist *sgl, int nents,
> goto out_unmap;
> }
> break;
> case PCI_P2PDMA_MAP_BUS_ADDR:
> sg->dma_address = pci_p2pdma_bus_addr_map(
> p2pdma_state.mem, sg_phys(sg));
> - sg_dma_len(sg) = sg->length;
> sg_dma_mark_bus_address(sg);
> - continue;
> + break;
> default:
> ret = -EREMOTEIO;
> goto out_unmap;
> }
> sg_dma_len(sg) = sg->length;
> }
Best regards
--
Marek Szyprowski, PhD
Samsung R&D Institute Poland