Re: [PATCH 3/3] staging: rtl8723bs: Renaming variables with type prefix

From: Greg KH

Date: Tue Jul 28 2026 - 03:37:45 EST


On Sun, Jul 19, 2026 at 11:54:51AM +0000, Dalvin-Ehinoma Noah Aiguobas wrote:
> Renaming deprecated variable names which use prefixes as type
> indicators to conform to the styleguide and for improved readability.
>
> Signed-off-by: Dalvin-Ehinoma Noah Aiguobas <fliegbert2@xxxxxxxxx>
> ---
> drivers/staging/rtl8723bs/core/rtw_mlme.c | 152 +++++++++++-----------
> 1 file changed, 76 insertions(+), 76 deletions(-)
>
> diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme.c b/drivers/staging/rtl8723bs/core/rtw_mlme.c
> index 114deeecc80f..7e3be8cbc829 100644
> --- a/drivers/staging/rtl8723bs/core/rtw_mlme.c
> +++ b/drivers/staging/rtl8723bs/core/rtw_mlme.c
> @@ -675,52 +675,52 @@ void rtw_survey_event_callback(struct adapter *adapter, u8 *pbuf)
> spin_unlock_bh(&pmlmepriv->lock);
> }
>
> -void rtw_surveydone_event_callback(struct adapter *adapter, u8 *pbuf)
> +void rtw_surveydone_event_callback(struct adapter *adapter, u8 *buf)
> {
> - struct mlme_priv *pmlmepriv = &adapter->mlmepriv;
> + struct mlme_priv *mlme_priv = &adapter->mlmepriv;

As you are changing all of the variables, this patch is hard to read and
verify that this is correct. Please only do one variable name at a
time.

thanks,

greg k-h