Re: [PATCH v3 0/1] pipe: only enable the extra wake_up(rd_wait) for edge-triggered consumers

From: Oleg Nesterov

Date: Fri Jul 31 2026 - 10:12:50 EST


On 07/31, Christian Brauner wrote:
>
> > But then we should name it "epoll_or_io_uring_pseudo_edgetrigger".
> > See the test-cases, they demonstrate the same pattern.
>
> Wouldn't pseudo_edgetrigger be sufficient? I think the comment as you
> wrote it is ok.

I agree with any naming ;) even if I personally don't think that "pseudo"
make the purpose any clearer, but this is minor.

It seems that Linus doesn't really like this patch "in general", lets wait
for reply from him...

Oleg.