Re: [PATCH v6 01/12] mm: rename pmd_to_softleaf_folio() to pmd_softleaf_to_folio()

From: Zi Yan

Date: Tue Aug 18 2026 - 14:39:35 EST


On 18 Aug 2026, at 9:09, Usama Arif wrote:

> pmd_to_softleaf_folio() converts the softleaf entry encoded by a PMD
> to a folio. Rename it to pmd_softleaf_to_folio() to make the conversion
> direction explicit and align it with softleaf_to_folio().
>
> No functional change.
>
> Suggested-by: Dev Jain <dev.jain@xxxxxxx>
> Signed-off-by: Usama Arif <usama.arif@xxxxxxxxx>
> ---
> include/linux/leafops.h | 4 ++--
> mm/huge_memory.c | 2 +-
> 2 files changed, 3 insertions(+), 3 deletions(-)
>
LGTM.

Reviewed-by: Zi Yan <ziy@xxxxxxxxxx>

Best Regards,
Yan, Zi