[PATCH v3 3/6] arm64: dts: qcom: lemans-evk-ifp-mezzanine: clean up PCI function nodes

From: Alex Elder

Date: Wed Sep 02 2026 - 18:19:12 EST


The lemans-evk-ifp-mezzanine overlay defines a node representing a
TC956x chip which contains a PCIe switch and an embedded endpoint
that implements two PCIe functions.

The devicetree nodes erroneously include a "pci" device_type property
for the two PCIe functions. That property should only be used for a
PCI device "that implements a PCI bus". Remove this property for the
two function nodes.

In addition, only PCI bridge nodes should be named "pcie@" (or "pci@").
PCI endpoint nodes are typically named based on the functionality they
implement (e.g., "ethernet@"). In this case, the role of these PCI
functions is not (yet) specified, and furthermore they will be used
with PCI endpoint buses. Rename these to use "dev@", following the
convention used in of_pci_make_dev_node() for dynamically-created
devicetree nodes.

Finally, these nodes define #address-cells, #size-cells, and ranges
properties, which are not normally defined for PCIe endpoints. Remove
these properties as well; they can be added back once they are actually
needed/used.

Reviewed-by: Manivannan Sadhasivam <manivannan.sadhasivam@xxxxxxxxxxxxxxxx>
Reviewed-by: Konrad Dybcio <konrad.dybcio@xxxxxxxxxxxxxxxx>
Reviewed-by: Abel Vesa <abel.vesa@xxxxxxxxxxxxxxxx>
Fixes: b64abb26a2916 ("arm64: dts: qcom: lemans-evk: Add IFP Mezzanine")
Signed-off-by: Alex Elder <elder@xxxxxxxxxxxx>
---
.../boot/dts/qcom/lemans-evk-ifp-mezzanine.dtso | 12 ++----------
1 file changed, 2 insertions(+), 10 deletions(-)

diff --git a/arch/arm64/boot/dts/qcom/lemans-evk-ifp-mezzanine.dtso b/arch/arm64/boot/dts/qcom/lemans-evk-ifp-mezzanine.dtso
index 6cfa0bc1440e9..e42314c648579 100644
--- a/arch/arm64/boot/dts/qcom/lemans-evk-ifp-mezzanine.dtso
+++ b/arch/arm64/boot/dts/qcom/lemans-evk-ifp-mezzanine.dtso
@@ -271,20 +271,12 @@ pcie@3,0 {
ranges;
bus-range = <0x5 0xff>;

- pcie@0,0 {
+ dev@0,0 {
reg = <0x50000 0x0 0x0 0x0 0x0>;
- #address-cells = <3>;
- #size-cells = <2>;
- device_type = "pci";
- ranges;
};

- pcie@0,1 {
+ dev@0,1 {
reg = <0x50100 0x0 0x0 0x0 0x0>;
- #address-cells = <3>;
- #size-cells = <2>;
- device_type = "pci";
- ranges;
};
};
};
--
2.53.0